Usando Linux para muchas cosas y disfrutando de videojuegos, en dispositivos moviles, consolas y pc. Using Linux for many things and enjoying video games, mobile devices, consoles and pc

Como instalar Open Ticket Request System paso a paso

Necesitas un sistema de tickets para manejar el soporte de tu negocio? Sigue leyendo y te mostrare como instalar Open Ticket Request System paso a paso en un Linux Centos 6.4.
Un sistema como OTRS te permitirá mantener bajo control el soporte que le brindas a tus clientes de una forma organizada y efectiva sin perder la cabeza ni elevarse los costos.

Requerimientos:


-Descargamos el rpm en su ultima versión.

wget -c http://ftp.otrs.org/pub/otrs/RPMS/rhel/6/otrs-3.2.10-02.noarch.rpm

-Instalamos dependencias

yum install httpd gcc perl-LDAP perl-TimeDate perl-Net-DNS
yum groupinstall 'Mysql Database server'

-Inicializamos MySQL. Cuidamos de colocar una buena contraseña a MySQL

service mysqld start
/usr/bin/mysqladmin -u root password 'contraseña'
/usr/bin/mysqladmin -u root -h vetkt password 'contraseña'
chkconfig mysqld on

-Modificamos MySQL y salimos guardando

vi /etc/my.cnf
max_allowed_packet=20M
query_cache_size=32M

-Reiniciamos el servicio

service mysqld restart

-Instalamos módulos de Perl

IO::Socket::SSL

-Instalamos

rpm -vi otrs-3.2.10-02.noarch.rpm

-Activamos servicios

service httpd restart
chkconfig httpd on

-Instalamos el repositorio Epel para instalar otros requerimientos. OJO, si tu server no es de 64bits, cambia x86_64 por i386. Continuamos instalando módulos

yum -y install http://download.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
yum -y install "perl(Text::CSV_XS)"

-Verificamos que nos falta de Perl por instalar. Los módulos marcados como optional solo son necesarios si vamos a usar su funcionalidad.

/opt/otrs/bin/otrs.CheckModules.pl
  o CGI..............................ok (v3.63)
  o Crypt::PasswdMD5.................ok (v1.3)
  o Crypt::SSLeay....................ok (v0.57)
  o CSS::Minifier....................ok (v0.01)
  o Date::Format.....................ok (v2.24)
  o Date::Pcalc......................ok (v1.2)
  o DBI..............................ok (v1.609)
  o DBD::mysql.......................ok (v4.013)
  o DBD::ODBC........................Not installed! (optional - Required to connect to a MS-SQL database.)
  o DBD::Oracle......................Not installed! (optional - Required to connect to a Oracle database.)
  o DBD::Pg..........................Not installed! (optional - Required to connect to a PostgreSQL database.)
  o Digest::MD5......................ok (v2.39)
  o Digest::SHA::PurePerl............ok (v5.81)
  o Digest::SHA......................ok (v5.47)
  o Encode::HanExtra.................Not installed! (optional - Required to handle mails with several Chinese character sets.)
  o Encode::Locale...................ok (v1.03)
  o GD...............................ok (v2.44)
    o GD::Text.......................Not installed! (optional - Required for stats.)
    o GD::Graph......................Not installed! (optional - Required for stats.)
  o IO::Scalar.......................ok (v2.110)
  o IO::Wrap.........................ok (v2.110)
  o JavaScript::Minifier.............ok (v1.05)
  o JSON.............................ok (v2.53)
    o JSON::PP.......................ok (v2.27200)
    o JSON::XS.......................Not installed! (optional - Recommended for faster AJAX/JavaScript handling.)
  o Locale::Codes....................ok (v3.24)
  o LWP::UserAgent...................ok (v6.04)
  o Mail::Internet...................ok (v2.12)
  o Mail::POP3Client.................ok (v1.2)
    o IO::Socket::SSL................ok (v1.954)
  o Mail::IMAPClient.................Not installed! (optional - Required for IMAP TLS connections.)
    o IO::Socket::SSL................ok (v1.954)
  o MIME::Base64.....................ok (v3.08)
  o MIME::Tools......................ok (v5.503)
  o ModPerl::Util....................ok (v2.000004)
    o Apache::DBI....................ok (v1.11)
    o Apache2::Reload................ok (v0.12)
  o Net::DNS.........................ok (v0.72)
  o Net::POP3........................ok (v2.29)
  o Net::IMAP::Simple................ok (v1.2034)
    o IO::Socket::SSL................ok (v1.954)
  o Net::SMTP........................ok (v2.31)
    o Authen::SASL...................ok (v2.16)
    o Net::SMTP::SSL.................ok (v1.01)
    o Net::SMTP::TLS::ButMaintained..ok (v0.20)
  o Net::LDAP........................ok (v0.40)
  o Net::SSL.........................ok (v2.84)
  o PDF::API2........................Not installed! (optional - Required for PDF output.)
    o Compress::Zlib.................ok (v2.020)
  o Storable.........................ok (v2.20)
  o SOAP::Lite.......................ok (v0.715)
    o version........................ok (v0.9902)
    o Class::Inspector...............ok (v1.28)
  o Text::CSV........................ok (v1.21)
    o Text::CSV_PP...................ok (v1.29)
    o Text::CSV_XS...................ok (v0.85)
  o Time::HiRes......................ok (v1.9721)
  o XML::Parser......................ok (v2.36)
  o HTTP::Message....................ok (v6.06)
    o HTTP::Headers..................ok (v6.05)
  o URI..............................ok (v1.60)
    o URI::Escape....................ok (v3.31)
  o Scalar::Util.....................ok (v1.21)
  o YAML::XS.........................Not installed! (required - use "perl -MCPAN -e shell;" - )

-Instalamos los que nos falten que necesitemos y volvemos a verificar

/opt/otrs/bin/otrs.CheckModules.pl
  o CGI..............................ok (v3.63)
  o Crypt::PasswdMD5.................ok (v1.3)
  o Crypt::SSLeay....................ok (v0.57)
  o CSS::Minifier....................ok (v0.01)
  o Date::Format.....................ok (v2.24)
  o Date::Pcalc......................ok (v1.2)
  o DBI..............................ok (v1.609)
  o DBD::mysql.......................ok (v4.013)
  o DBD::ODBC........................Not installed! (optional - Required to connect to a MS-SQL database.)
  o DBD::Oracle......................Not installed! (optional - Required to connect to a Oracle database.)
  o DBD::Pg..........................Not installed! (optional - Required to connect to a PostgreSQL database.)
  o Digest::MD5......................ok (v2.39)
  o Digest::SHA::PurePerl............ok (v5.81)
  o Digest::SHA......................ok (v5.47)
  o Encode::HanExtra.................Not installed! (optional - Required to handle mails with several Chinese character sets.)
  o Encode::Locale...................ok (v1.03)
  o GD...............................ok (v2.44)
    o GD::Text.......................ok (v0.86)
    o GD::Graph......................ok (v1.44)
  o IO::Scalar.......................ok (v2.110)
  o IO::Wrap.........................ok (v2.110)
  o JavaScript::Minifier.............ok (v1.05)
  o JSON.............................ok (v2.53)
    o JSON::PP.......................ok (v2.27200)
    o JSON::XS.......................ok (v2.27)
  o Locale::Codes....................ok (v3.24)
  o LWP::UserAgent...................ok (v6.04)
  o Mail::Internet...................ok (v2.12)
  o Mail::POP3Client.................ok (v1.2)
    o IO::Socket::SSL................ok (v1.954)
  o Mail::IMAPClient.................ok (v3.33)
    o IO::Socket::SSL................ok (v1.954)
  o MIME::Base64.....................ok (v3.08)
  o MIME::Tools......................ok (v5.503)
  o ModPerl::Util....................ok (v2.000004)
    o Apache::DBI....................ok (v1.11)
    o Apache2::Reload................ok (v0.12)
  o Net::DNS.........................ok (v0.72)
  o Net::POP3........................ok (v2.29)
  o Net::IMAP::Simple................ok (v1.2034)
    o IO::Socket::SSL................ok (v1.954)
  o Net::SMTP........................ok (v2.31)
    o Authen::SASL...................ok (v2.16)
    o Net::SMTP::SSL.................ok (v1.01)
    o Net::SMTP::TLS::ButMaintained..ok (v0.20)
  o Net::LDAP........................ok (v0.40)
  o Net::SSL.........................ok (v2.84)
  o PDF::API2........................ok (v2.019)
    o Compress::Zlib.................ok (v2.020)
  o Storable.........................ok (v2.20)
  o SOAP::Lite.......................ok (v0.715)
    o version........................ok (v0.9902)
    o Class::Inspector...............ok (v1.28)
  o Text::CSV........................ok (v1.21)
    o Text::CSV_PP...................ok (v1.29)
    o Text::CSV_XS...................ok (v0.85)
  o Time::HiRes......................ok (v1.9721)
  o XML::Parser......................ok (v2.36)
  o HTTP::Message....................ok (v6.06)
    o HTTP::Headers..................ok (v6.05)
  o URI..............................ok (v1.60)
    o URI::Escape....................ok (v3.31)
  o Scalar::Util.....................ok (v1.21)
  o YAML::XS.........................ok (v0.38)

-Abrimos un browser y navegamos a la ip del servidor y damos click al botón Next. http://192.168.1.118/otrs/installer.pl

-Aceptamos la licencia

-Llenamos los campos con la info del servidor MySQL, en este caso localhost y la cuenta root con su contraseña. Después de la verificación colocamos los datos para la cuenta en MySQL con que se conectara OTRS y damos click al botón Next

-La db es creada con éxito. Damos click al botón Next

-Hora de escribir los datos de nuestro servidor. Si como en este caso el servidor no estará publico en internet, debemos marcar No para que no se verifiquen estos datos por medio de DNS. Damos click al botón Next

-La configuración del email la podemos hacer en este momento o saltarla para hacerla mas tarde dando click al botón Skip this step

-Se nos alertara de que no se registrara nuestro OTRS, damos click al botón OK

-Ya esta instalado nuestro OTRS y el sistema nos muestra los datos de ingreso que son root@localhost y la contraseña root la cual debemos cambiar apenas entremos por motivos de seguridad. Damos click al link para ingresar

-Ingresamos con nuestro usuario root

-Y el sistema nos recibe en el DASHBOARD de OTRS alertándonos de que no es bueno trabajar desde esta cuenta y que creemos una cuenta para eso

-Vamos al perfil de root para cambiar la contraseña. Damos click en su nombre en la esquina superior derecha y después de cambiarla en el botón Update. Ya que estamos aquí si queremos podemos cambiar el idioma de la interfaz, el estilo, etc.

Con esto terminamos de instalar y configurar OTRS, los siguientes pasos serian crear agentes, grupos y colas para los tickets. Lo usas ya? Tienes otro sistema de tickets en tu negocio, cual?
Si te resulto útil este articulo, se social, compártelo con otros por medio de los botones o sígueme en twitter google+ o email y podrás estar enterado de todas mis publicaciones.
Disfrútenlo.

Share/Bookmark